It appears Attansic was recently bought by Atheros. However, getting it to work on GNU/Debian Lenny is as simple as:

apt-get install atl2-modules-2.6-686
modprobe atl2

And here it is:

root@gw # ifconfig eth1
     eth1      Link encap:Ethernet  HWaddr 00:1e:8c:18:88:a6
     BROADCAST MULTICAST  MTU:1500  Metric:1
     RX packets:0 errors:0 dropped:0 overruns:0 frame:0
     TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
     collisions:0 txqueuelen:1000
     RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
     Memory:dffc0000-e0000000

Comments